[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Redhat : Updated PAM packages fix bug in pam_xauth module



- ---------------------------------------------------------------------
                   Red Hat, Inc. Red Hat Security Advisory

Synopsis:          Updated PAM packages fix bug in pam_xauth module
Advisory ID:       RHSA-2003:035-10
Issue date:        2003-02-07
Updated on:        2003-02-12
Product:           Red Hat Linux
Keywords:          pam_xauth root cookies
Cross references:  RHSA-2003:028
Obsoletes:         
CVE Names:         CAN-2002-1160
- ---------------------------------------------------------------------

1. Topic:

Updated PAM packages are now available for Red Hat Linux 7.1, 7.2, 7.3, and
8.0.  These packages correct a bug in pam_xauth's handling of authorization
data for the root user.

2. Relevant releases/architectures:

Red Hat Linux 7.1 - i386
Red Hat Linux 7.2 - i386, ia64
Red Hat Linux 7.3 - i386
Red Hat Linux 8.0 - i386

3. Problem description:

The pam_xauth module is used to forward xauth information from user to user
in applications such as 'su'.

Andreas Beck discovered that versions of pam_xauth supplied with Red Hat
Linux since version 7.1 would forward authorization information from the
root account to unprivileged users. This could be used by a local attacker
to gain access to an administrator's X session. In order to exploit this
vulnerability, the attacker would have to get the administrator, as root,
to use su to the account belonging to the attacker.

Users of pam_xauth are advised to upgrade to these errata packages, which
contain a patch that adds ACL (access control list) functionality to
pam_xauth and disallows root forwarding by default.

Versions of pam_xauth included in Red Hat Linux 7 and earlier disabled
passing of credentials from the root account to unprivileged users by
default and are not affected by this issue.

Thanks to Andreas Beck for reporting this issue.

4. Solution:

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

To update all RPMs for your particular architecture, run:

rpm -Fvh [filenames]

where [filenames] is a list of the RPMs you wish to upgrade.  Only those
RPMs which are currently installed will be updated.  Those RPMs which are
not installed but included in the list will not be updated.  Note that you
can also use wildcards (*.rpm) if your current directory *only* contains the
desired RPMs.

Please note that this update is also available via Red Hat Network.  Many
people find this an easier way to apply updates.  To use Red Hat Network,
launch the Red Hat Update Agent with the following command:

up2date

This will start an interactive process that will result in the appropriate
RPMs being upgraded on your system.

5. RPMs required:

Red Hat Linux 7.1:

SRPMS:
ftp://updates.redhat.com/7.1/en/os/SRPMS/pam-0.75-46.7.1.src.rpm

i386:
ftp://updates.redhat.com/7.1/en/os/i386/pam-0.75-46.7.1.i386.rpm
ftp://updates.redhat.com/7.1/en/os/i386/pam-devel-0.75-46.7.1.i386.rpm

Red Hat Linux 7.2:

SRPMS:
ftp://updates.redhat.com/7.2/en/os/SRPMS/pam-0.75-46.7.2.src.rpm

i386:
ftp://updates.redhat.com/7.2/en/os/i386/pam-0.75-46.7.2.i386.rpm
ftp://updates.redhat.com/7.2/en/os/i386/pam-devel-0.75-46.7.2.i386.rpm

ia64:
ftp://updates.redhat.com/7.2/en/os/ia64/pam-0.75-46.7.2.ia64.rpm
ftp://updates.redhat.com/7.2/en/os/ia64/pam-devel-0.75-46.7.2.ia64.rpm

Red Hat Linux 7.3:

SRPMS:
ftp://updates.redhat.com/7.3/en/os/SRPMS/pam-0.75-46.7.3.src.rpm

i386:
ftp://updates.redhat.com/7.3/en/os/i386/pam-0.75-46.7.3.i386.rpm
ftp://updates.redhat.com/7.3/en/os/i386/pam-devel-0.75-46.7.3.i386.rpm

Red Hat Linux 8.0:

SRPMS:
ftp://updates.redhat.com/8.0/en/os/SRPMS/pam-0.75-46.8.0.src.rpm

i386:
ftp://updates.redhat.com/8.0/en/os/i386/pam-0.75-46.8.0.i386.rpm
ftp://updates.redhat.com/8.0/en/os/i386/pam-devel-0.75-46.8.0.i386.rpm



6. Verification:

MD5 sum                          Package Name
- --------------------------------------------------------------------------
4a869dd0efd82fb9f098cc4284263aeb 7.1/en/os/SRPMS/pam-0.75-46.7.1.src.rpm
2ee6c4e7c9c59efdf3e31c8d9482a30a 7.1/en/os/i386/pam-0.75-46.7.1.i386.rpm
0d8f6cb6d0f293cb174f3e376c21eb1d 7.1/en/os/i386/pam-devel-0.75-46.7.1.i386.rpm
fcbe7194fc12466d4532b213373c3ce6 7.2/en/os/SRPMS/pam-0.75-46.7.2.src.rpm
7d16c011e4f74e8e02bb8c193506186d 7.2/en/os/i386/pam-0.75-46.7.2.i386.rpm
0919b62d8d7531883d6e01f5ff3a51b6 7.2/en/os/i386/pam-devel-0.75-46.7.2.i386.rpm
e653e3ff25eb958570b411d201b5106e 7.2/en/os/ia64/pam-0.75-46.7.2.ia64.rpm
8f4d0dc64cdbded20c46a38460e6affe 7.2/en/os/ia64/pam-devel-0.75-46.7.2.ia64.rpm
99751631043fbe42f98f8598e74e6d4b 7.3/en/os/SRPMS/pam-0.75-46.7.3.src.rpm
8ea6d868c28c22d629d2059f1ad72f1b 7.3/en/os/i386/pam-0.75-46.7.3.i386.rpm
9fef754632838504c0590ba30203a925 7.3/en/os/i386/pam-devel-0.75-46.7.3.i386.rpm
1b74821ca4fd0b7a9919c3b0fdf3dbb3 8.0/en/os/SRPMS/pam-0.75-46.8.0.src.rpm
25ebcb39f56c98cc064c34b2d048ed35 8.0/en/os/i386/pam-0.75-46.8.0.i386.rpm
f6412156d54a4021a3200eb7d7ff79c0 8.0/en/os/i386/pam-devel-0.75-46.8.0.i386.rpm


These packages are GPG signed by Red Hat, Inc. for security.  Our key
is available at http://www.redhat.com/about/contact/pgpkey.html

You can verify each package with the following command:
    
    rpm --checksig -v <filename>

If you only wish to verify that each package has not been corrupted or
tampered with, examine only the md5sum with the following command:
    
    md5sum <filename>


7. References:

http://www.redhat.com/support/wpapers/redhat/newpam/tinkering.html
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2002-1160

8. Contact:

The Red Hat security contact is <security@redhat.com>.  More contact
details at http://www.redhat.com/solutions/security/news/contact.html

Copyright 2003 Red Hat, Inc.