[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Fw: SGI Security Coordinator: [VulnWatch] IRIX File globbing vulnerability in ftpd



_________________________________________________________________________=
_____
                          SGI Security Advisory

        Title:   File globbing vulnerability in ftpd
        Number:  20010802-01-P
     Reference:  CERT=AE Advisory CA-2001-07
     Reference:  CVE CAN-2001-0247
        Date:    August, 28 2001
_________________________________________________________________________=
_____

SGI provides this information freely to the SGI user community for its
consideration, interpretation, implementation and use.   SGI recommends
that this information be acted upon as soon as possible.

SGI provides the information in this Security Advisory on an "AS-IS" basi=
s
only, and disclaims all warranties with respect thereto, express, implied=

or otherwise, including, without limitation, any warranty of merchantabil=
ity
or fitness for a particular purpose.  In no event shall SGI be liable for=

any loss of profits, loss of business, loss of data or for any indirect,
special, exemplary, incidental or consequential damages of any kind arisi=
ng
from your use of, failure to use or improper use of any of the instructio=
ns
or information in this Security Advisory.
_________________________________________________________________________=
_____


- - -----------------------
- - --- Issue Specifics ---
- - -----------------------

NAI COVERT Labs reported a file globbing vulnerability in ftpd daemon
which can lead to a root compromise.

SGI has investigated the issue and recommends the following steps for
neutralizing the exposure.  It is HIGHLY RECOMMENDED that these measures
neutralizing the exposure.  It is HIGHLY RECOMMENDED that these measures
be implemented on ALL vulnerable SGI systems.  This issue has been
corrected in future releases of IRIX.


- - --------------
- - --- Impact ---
- - --------------

The ftpd(1M) daemon is installed by default on IRIX.

A local user account on the vulnerable system is not required in order
to exploit ftpd daemon.  The ftpd daemon can be exploited remotely over
an untrusted network.

The exploitable buffer overflow vulnerability can lead to a root compromi=
se.

NAI Covert Labs reported the ftp server vulnerability:
http://www.pgp.com/research/covert/advisories/048.asp

The ftpd vulnerability was also reported by CERT=AE Advisory CA-2001-07:
http://www.cert.org/advisories/CA-2001-07.html

This ftpd vulnerability was assigned the following CVE:
http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCAN-2001-0247

This ftpd vulnerability has been publicly discussed in Usenet newsgroups
and mailing lists.


- - --------------------------
- - --- Temporary Solution ---
- - --------------------------

Although patches are available for this issue, it is realized that
there may be situations where installing the patches immediately may
not be possible.

The steps below can be used to disable the ftpd(1M) daemon to prevent
exploitation of this vulnerability until patches can be installed.


      =3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D
      **** WARNING ****
      =3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

      These steps will disable the ftp server.

     1) Become the root user on the system.

                % /bin/su -
                Password:
                #

     2) Edit the file /etc/inetd.conf and place a "#" as the first
        character of the ftp line to comment out and deactivate the
        service.


                # vi  /etc/inetd.conf

       {Find the following line}

       ftp   stream  tcp   nowait  root   /usr/etc/ftpd   ftpd -l

       {Place a "#" as the first character of the ftp line}

       #ftp   stream  tcp   nowait  root   /usr/etc/ftpd   ftpd -l

       {Save the file and exit}


     3) Force inetd to re-read the configuration file.

                # /etc/killall -HUP inetd

     4) Kill any existing ftpd process.

                # /etc/killall ftpd


     5) Return to previous level.

                # exit
                %


- - ----------------
- - --- Solution ---
- - ----------------


   OS Version     Vulnerable?     Patch #      Other Actions
   ----------     -----------     -------      -------------
   IRIX 3.x        unknown                     Note 1
   IRIX 4.x        unknown                     Note 1
   IRIX 5.x        unknown                     Note 1
   IRIX 6.0.x      unknown                     Note 1
   IRIX 6.1        unknown                     Note 1
   IRIX 6.2        unknown                     Note 1
   IRIX 6.3        unknown                     Note 1
   IRIX 6.4        unknown                     Note 1
   IRIX 6.5          yes           4270        Note 2 & 3
   IRIX 6.5.1        yes           4270        Note 2 & 3
   IRIX 6.5.2        yes           4270        Note 2 & 3
   IRIX 6.5.3        yes           4270        Note 2 & 3
   IRIX 6.5.4        yes           4270        Note 2 & 3
   IRIX 6.5.5        yes           4270        Note 2 & 3
   IRIX 6.5.6        yes           4270        Note 2 & 3
   IRIX 6.5.7        yes           4270        Note 2 & 3
   IRIX 6.5.8        yes           4270        Note 2 & 3
   IRIX 6.5.9        yes           4270        Note 2 & 3
   IRIX 6.5.10       yes           4270        Note 2 & 3
   IRIX 6.5.11       yes           4270        Note 2 & 3
   IRIX 6.5.12       yes           4270        Note 2 & 3
   IRIX 6.5.13       no                        Note 4 & 5


   NOTES

     1) This version of the IRIX operating has been retired.
        Upgrade to an actively supported IRIX operating system.
        See http://support.sgi.com/irix/news/index.html#policy
        for more information.

     2) This version of the IRIX operating system is in maintenance mode.=

        Upgrade to an actively supported IRIX operating system.
        See http://support.sgi.com/irix/news/index.html#policy
        for more information.

     3) See "Temporary Solution" section.

     4) Download the IRIX 6.5.13 Maintenance Release Stream from the URL:=

        http://support.sgi.com/colls/patches/tools/relstream/index.html

     5) If you have not received an IRIX 6.5.X CD for IRIX 6.5, contact y=
our
        SGI Support Provider or URL: http://support.sgi.com/irix/swupdate=
s/



Patches are available via the web, anonymous FTP and from your SGI
service/support provider.

SGI Security Advisories can be found at:
http://www.sgi.com/support/security/ and
ftp://patches.sgi.com/support/free/security/advisories/

SGI Security Patches can be found at:
http://www.sgi.com/support/security/ and
ftp://patches.sgi.com/support/free/security/patches/

SGI patches for IRIX can be found at the following patch servers:
http://support.sgi.com/irix/ and ftp://patches.sgi.com/

SGI freeware updates for IRIX can be found at:
http://freeware.sgi.com/

SGI fixes for SGI open sourced code can be found on:
http://oss.sgi.com/projects/

SGI patches and RPMs for Linux can be found at:
http://support.sgi.com/linux/ or
http://oss.sgi.com/projects/sgilinux-combined/download/security-fixes/

SGI patches for Windows NT or 2000 can be found at:
http://support.sgi.com/nt/

IRIX 5.2-6.4 Recommended/Required Patch Sets can be found at:
http://support.sgi.com/irix/ and ftp://patches.sgi.com/support/patchset/

IRIX 6.5 Maintenance Release Streams can be found at:
http://support.sgi.com/colls/patches/tools/relstream/index.html

IRIX 6.5 Software Update CDs can be obtained from:
http://support.sgi.com/irix/swupdates/

The primary SGI anonymous FTP site for security advisories and patches
is patches.sgi.com (216.32.174.211).  Security advisories and patches
are located under the URL ftp://patches.sgi.com/support/free/security/

For security and patch management reasons, ftp.sgi.com (mirrors
patches.sgi.com security FTP repository) lags behind and does not
do a real-time update.


                 ##### Patch File Checksums ####

The actual patch will be a tar file containing the following files:

Filename:                 README.patch.4270
Algorithm #1 (sum -r):    12497 8 README.patch.4270
Algorithm #2 (sum):       34418 8 README.patch.4270
MD5 checksum:             EBF634B7F6C4B87F7E0178F26EAFEE5A

Filename:                 patchSG0004270
Algorithm #1 (sum -r):    18303 4 patchSG0004270
Algorithm #2 (sum):       56841 4 patchSG0004270
MD5 checksum:             08A70D53F1FC81E4AB4B462394BF2CA1

Filename:                 patchSG0004270.eoe_sw
Algorithm #1 (sum -r):    63206 117 patchSG0004270.eoe_sw
Algorithm #2 (sum):       11262 117 patchSG0004270.eoe_sw
MD5 checksum:             8F359DA297E29553FA0D281BA1FB1110

Filename:                 patchSG0004270.idb
Algorithm #1 (sum -r):    59260 1 patchSG0004270.idb
Algorithm #2 (sum):       33639 1 patchSG0004270.idb
MD5 checksum:             6CBBF5B738604C469A017C881646071D


- - ------------------------
- - --- Acknowledgments ----
- - ------------------------

SGI wishes to thank the NAI COVERT Labs, CERT Coordination Center and
the users of the Internet Community at large for their assistance
in this matter.


- - -----------------------------------------
- - --- SGI Security Information/Contacts ---
- - -----------------------------------------

If there are questions about this document, email can be sent to
security-info@sgi.com.

                      ------oOo------

SGI provides security information and patches for use by the entire SGI
community.  This information is freely available to any person needing
the information and is available via anonymous FTP and the Web.

The primary SGI anonymous FTP site for security advisories and patches
is patches.sgi.com (216.32.174.211).  Security advisories and patches
are located under the URL ftp://patches.sgi.com/support/free/security/

The SGI Security Headquarters Web page is accessible at the URL:
http://www.sgi.com/support/security/

For issues with the patches on the FTP sites, email can be sent to
security-info@sgi.com.

For assistance obtaining or working with security patches, please
contact your SGI support provider.

                      ------oOo------

SGI provides a free security mailing list service called wiretap and
encourages interested parties to self-subscribe to receive (via email) al=
l
SGI Security Advisories when they are released. Subscribing to the mailin=
g
list can be done via the Web (http://www.sgi.com/support/security/wiretap=
=2Ehtml)
or by sending email to SGI as outlined below.

% mail wiretap-request@sgi.com
subscribe wiretap <YourEmailAddress>
end
^d

In the example above, <YourEmailAddress> is the email address that you
wish the mailing list information sent to.  The word end must be on a
separate line to indicate the end of the body of the message. The
control-d (^d) is used to indicate to the mail program that you are
finished composing the mail message.


                      ------oOo------

SGI provides a comprehensive customer World Wide Web site. This site is
located at http://www.sgi.com/support/security/ .

                      ------oOo------

If there are gerneral security questions on SGI systems, email can be
sent to security-info@sgi.com.

For reporting *NEW* SGI security issues, email can be sent to
security-alert@sgi.com or contact your SGI support provider.  A
support contract is not required for submitting a security report.

_________________________________________________________________________=
_____
      This information is provided freely to all interested parties
      and may be redistributed provided that it is not altered in any
      way, SGI is appropriately credited and the document retains and
      includes its valid PGP signature.